Xcode是苹果公司向开发人员提供的集成开发环境,用于开发macOS、iOS、WatchOS和tvOS的应用程序。WWDC18全球开发者大会上,苹果发布了macOS Mojave beta测试版系统,并且还推出了全新的Xcode 10 beta测试版,Xcode 10 beta测试版内包括了适用于iOS 12、macOS Mojave、watchOS 5、tvOS 12开发的SDK工具,还有一系列提升效率的软件和工具等,能够构建更具交互性和智能的应用体验。

 

        在Xcode 10中通过很简单的配置即可在无开发者账号的情况下进行真机调试, 同时还支持无线网络环境下的真机调试(Mac和iPhone需要连接到同一台路由器并处于同一个局域网中), 对于开发者来说非常方便, 以下是详细的设置步骤:

 

一.教程环境:

  1. macOS 10.13.6
  2. ios 11.4
  3. Xcode 10.0

继续阅读

MSI B150M GTX1080 macOS High Sierra 黑苹果安装教程

安装黑苹果的方式多种多样,本教程主要适用于使用以下或类似配置的台式机:

1.配置信息


  • 处理器:  英特尔(Intel) i5-5600 3.20 GHz
  • 主    板:  微星(MSI) B150M MORTAR
  • 内    存:  金士顿(Kingston) Fury DDR4 2400 16GB
  • 显    卡:  微星(MSI) GeForce GTX 1080 GAMING X
  • 声    卡:  板载 Realtek ALC892
  • 硬    盘:  HP S700 SSD 120G SATA
  • 蓝    牙:  奥睿科(ORICO) BTA-403-BL USB 蓝牙4.0

继续阅读

MSSQL ERROR: Create Failed For User ‘UserName’

When you restore or migrating your MSSQL database from one to another server, below error message may appear:

Create failed for user ‘UserName’. (Microsoft.SqlServer.Smo)

Additional Information:
An exception occurred while executing a Transact-SQL statement or batch.
(Microsoft.SqlServer.ConnectionInfo)
User, group, or role ‘UserName’ already exists in the current database. (Microsoft SQL Server, Error: 15023)

You can simple to solve the issue by maps an existing user in a database to a MSSQL Server login:

继续阅读

关于如何更改Dell OpenManage(OMSA)界面的语言

OpenManage系统管理方案是戴尔公司基于自主研发力量开发的IT系统管理解决方案,通过OpenManage管理系统用户可以方便快速的实现服务器的部署、服务器状态的监控和系统更新等。OpenManage管理系统为用户降低了服务器管理的复杂度,提高工作效率,减少维护和部署的时间,对于IT经验不足的企业来说是个非常好的助手。OpenManage具备标准化的能源监控和警报功能,能够提供各种能源使用信息,确保IT人员能够及时且准确地了解服务器的使用情况,减少总体能耗和成本。

戴尔OpenManage管理系统随戴尔服务器产品附送,并可以通过戴尔官方网站下载,是一个免费的管理工具,这也是OpenManage最大的优点之一。OpenMange软件支持多种语言,但是在它的配置界面中无法直接切换,需要通过更改IE的语言来设置:

1.打开IE浏览器。

image

继续阅读

When you try to use the Lifecycle Platform (F10) Updates option in System Services to update firmware, you may get the following error:  “The updates you are trying to apply are not Dell-authorized updates”.

Symptom:

Error message “The updates you are trying to apply are not Dell-authorized updates”

The updates you are trying to apply are not Dell-authorized updates

The updates you are trying to apply are not Dell-authorized updates

继续阅读